Friday, August 20, 2010

Android requires .class compatibility set to 5.0. Please fix project properties.

I've created a new workspace in Eclipse & imported an Android project.

* Issue #1:
Android requires .class compatibility set to 5.0. Please fix project properties.

* Solution:
1. Fix project:
Package Explorer ->
Right click the project ->
"Android Tools" -> "Fix Project Properties"
2. Restart Eclipse:
"File" -> "Restart"

* Issue #2: The following error appears many times
The method xyz() of type ABC must override a superclass method

* Solution:
1. Fix the project again:
Package Explorer ->
Right click the project ->
"Properties" -> "Java Compiler" -> "Compiler Compliance Level" = 1.6

4 comments:

Jia Cherng Ho said...

Thank you so much, this fixed exactly the problems which you described.

Bùi Minh Triết said...

Thanks so much. At first I think Android Tools -> Fix Project Properties is enough. But I mistake, because after that I must change Java compiler to 1.6 to fix all the bugs.

TUM BIN said...

Thanks a lot buddy

TUM BIN said...

Thanks a lot buddy